# FrankenPHP: Cross-request PHP session ID leak in worker mode when the session extension is a shared module

Advisory record · `GHSA-v3ph-cgqh-r8p5`

- **Identifiers:** `GHSA-v3ph-cgqh-r8p5` · `CVE-2026-82416` · `GO-2026-6797`
- **State:** Confirmed
- **Severity:** CVSS 7.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-362](https://cwe.mitre.org/data/definitions/362.html) · [CWE-488](https://cwe.mitre.org/data/definitions/488.html)
- **Tags:** [Race condition](https://agentprime.io/advisories/tag/race-condition.md) · [CWE-488](https://agentprime.io/advisories/tag/cwe-488.md)
- **Published:** 15 Oct 2026
- **Updated:** 19 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 15 Oct 2026, 20:14 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/dunglas/frankenphp` (Go): affected `<1.12.5`; fixed in `1.12.5`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Affected: github.com/dunglas/frankenphp versions before 1.12.5, when PHP's session extension is loaded as a shared module rather than statically compiled in (for example, RPM and Debian packages). In worker mode under concurrent load, a request can receive another client's session ID or a stale one from a prior request, enabling cross-user session exposure and hijacking. Upgrade to 1.12.5. Statically linked builds, such as the official binaries and Docker images, are not affected.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.7 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0029, the 21st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:11 UTC: First seen by agentprime
- 31 Oct 2026, 14:11 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-v3ph-cgqh-r8p5)

## Sources

- [GitHub Advisory Database: GHSA-v3ph-cgqh-r8p5](https://github.com/advisories/GHSA-v3ph-cgqh-r8p5)
- [OSV: GHSA-v3ph-cgqh-r8p5](https://osv.dev/vulnerability/GHSA-v3ph-cgqh-r8p5)
- <https://github.com/php/frankenphp/security/advisories/GHSA-v3ph-cgqh-r8p5>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-82416>
- <https://github.com/php/frankenphp/pull/2523>
- <https://github.com/php/frankenphp/commit/be24d82531675f90862b8cde1e9fc7e9ee855aa5>
- <https://github.com/php/frankenphp>
- <https://github.com/php/frankenphp/releases/tag/caddy/v1.12.5>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-v3ph-cgqh-r8p5>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-v3ph-cgqh-r8p5/>. Everything for agents: <https://agentprime.io/llms.txt>.
