# Apache HttpComponents Core: HPackDecoder Unlimited Header List Size Before SETTINGS ACK

Advisory record · `GHSA-v3jc-474w-2wm6`

- **Identifiers:** `GHSA-v3jc-474w-2wm6` · `CVE-2026-54428`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-400](https://cwe.mitre.org/data/definitions/400.html) · [CWE-770](https://cwe.mitre.org/data/definitions/770.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 1 Jul 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 Jul 2026, 18:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.apache.httpcomponents.core5:httpcore5-h2` (Maven): affected `<5.4.3 || >=5.5-alpha1, <5.5-beta2`; fixed in `5.4.3`, `5.5-beta2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Apache HttpComponents Core httpcore5-h2 versions before 5.4.3 and from 5.5-alpha1 up to but not including 5.5-beta2 are vulnerable. A remote attacker can send oversized compressed HTTP/2 header blocks before the SETTINGS acknowledgement, which prevents the configured header list size limit from applying and can exhaust memory, causing a denial of service. Upgrade to version 5.4.3 or 5.5-beta2.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0087, the 59th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:16 UTC: First seen by agentprime
- 31 Oct 2026, 14:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-v3jc-474w-2wm6)

## Sources

- [GitHub Advisory Database: GHSA-v3jc-474w-2wm6](https://github.com/advisories/GHSA-v3jc-474w-2wm6)
- [OSV: GHSA-v3jc-474w-2wm6](https://osv.dev/vulnerability/GHSA-v3jc-474w-2wm6)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-54428>
- <https://github.com/apache/httpcomponents-core/commit/1ea1239bbbe3442a8382a87279c0a8119a7e358e>
- <https://github.com/apache/httpcomponents-core/commit/cc30ee058a7b10cbf4ad3dd6270ab6d1f6a74c49>
- <https://github.com/apache/httpcomponents-core>
- <https://lists.apache.org/thread/5zjp8vczvxq19pw2rvhs21q446bhl0sd>
- <http://www.openwall.com/lists/oss-security/2026/07/01/3>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-v3jc-474w-2wm6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-v3jc-474w-2wm6/>. Everything for agents: <https://agentprime.io/llms.txt>.
