# Keycloak Reflected XSS

Advisory record · `GHSA-v38p-mqq3-m6v5`

- **Identifiers:** `GHSA-v38p-mqq3-m6v5` · `CVE-2017-12158`
- **State:** Confirmed
- **Severity:** CVSS 5.4 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html) · [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md) · [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md)
- **Published:** 13 May 2022
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 13 May 2022, 01:38 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.keycloak:keycloak-parent` (Maven): affected `<3.4.0`; fixed in `3.4.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Keycloak (org.keycloak:keycloak-parent, Maven) versions before 3.4.0 are vulnerable. The source says Keycloak accepted a HOST header URL in the admin console and used it to determine web resource locations, so an attacker could cause reflected cross-site scripting against an authenticated user via a malicious server. Upgrade to version 3.4.0 or later.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.4 Medium, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.010, the 63rd percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:18 UTC: First seen by agentprime
- 31 Oct 2026, 14:18 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-v38p-mqq3-m6v5)

## Sources

- [GitHub Advisory Database: GHSA-v38p-mqq3-m6v5](https://github.com/advisories/GHSA-v38p-mqq3-m6v5)
- [OSV: GHSA-v38p-mqq3-m6v5](https://osv.dev/vulnerability/GHSA-v38p-mqq3-m6v5)
- <https://nvd.nist.gov/vuln/detail/CVE-2017-12158>
- <https://access.redhat.com/errata/RHSA-2017:2904>
- <https://access.redhat.com/errata/RHSA-2017:2905>
- <https://access.redhat.com/errata/RHSA-2017:2906>
- <https://bugzilla.redhat.com/show_bug.cgi?id=1489161>
- <https://web.archive.org/web/20210124114020/http://www.securityfocus.com/bid/101618>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-v38p-mqq3-m6v5>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-v38p-mqq3-m6v5/>. Everything for agents: <https://agentprime.io/llms.txt>.
