# Infrahub: Deleted and expired API tokens can still authenticate

Advisory record · `GHSA-v2p7-4pv4-3wwh`

- **Identifiers:** `GHSA-v2p7-4pv4-3wwh` · `CVE-2025-59036` · `PYSEC-2026-1463`
- **State:** Confirmed
- **Severity:** CVSS 5.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-298](https://cwe.mitre.org/data/definitions/298.html)
- **Tags:** [CWE-298](https://agentprime.io/advisories/tag/cwe-298.md)
- **Published:** 10 Sept 2025
- **Updated:** 7 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 10 Sept 2025, 20:47 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `infrahub-server` (PyPI): affected `<1.3.9 || >=1.4.0, <1.4.5`; fixed in `1.3.9`, `1.4.5`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0019, the 9th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 10 Sept 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-v2p7-4pv4-3wwh](https://github.com/advisories/GHSA-v2p7-4pv4-3wwh)
- [OSV: GHSA-v2p7-4pv4-3wwh](https://osv.dev/vulnerability/GHSA-v2p7-4pv4-3wwh)
- <https://github.com/opsmill/infrahub/security/advisories/GHSA-v2p7-4pv4-3wwh>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-59036>
- <https://github.com/opsmill/infrahub/commit/215185f217e2f754f7c0a0aa4b77e11079a063a1>
- <https://github.com/opsmill/infrahub/commit/61b49a4a9e988f10c3a44f0e86ef97f344a1e228>
- <https://github.com/opsmill/infrahub>
- <https://github.com/opsmill/infrahub/releases/tag/infrahub-v1.3.9>
- <https://github.com/opsmill/infrahub/releases/tag/infrahub-v1.4.5>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-v2p7-4pv4-3wwh>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-v2p7-4pv4-3wwh/>. Everything for agents: <https://agentprime.io/llms.txt>.
