# gix-path uses local config across repos when it is the highest scope

Advisory record · `GHSA-v26r-4c9c-h3j6`

- **Identifiers:** `GHSA-v26r-4c9c-h3j6` · `CVE-2024-45305` · `RUSTSEC-2024-0367`
- **State:** Confirmed
- **Severity:** CVSS 2.5 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-706](https://cwe.mitre.org/data/definitions/706.html)
- **Tags:** [CWE-706](https://agentprime.io/advisories/tag/cwe-706.md)
- **Published:** 31 Aug 2024
- **Updated:** 12 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 31 Aug 2024, 12:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `gix-path` (crates.io): affected `>=0.0.0-0, <0.10.10`; fixed in `0.10.10`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> GHSA-v26r-4c9c-h3j6: gix-path versions before 0.10.10 treat a local repository's git configuration as system-wide when no higher-scope configuration is present. An attacker who can get a user to run gix from inside one repository while operating on another, or who arranges for higher-scope configuration to be absent, could cause that repository's settings, including credentials, to be applied to a different repository's remote. Upgrade gix-path to 0.10.10 or later.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.5 Low, CVSS 3.1: `CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0024, the 15th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:24 UTC: First seen by agentprime
- 31 Oct 2026, 14:24 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/RUSTSEC-2024-0367)

## Sources

- [GitHub Advisory Database: GHSA-v26r-4c9c-h3j6](https://github.com/advisories/GHSA-v26r-4c9c-h3j6)
- [OSV: GHSA-v26r-4c9c-h3j6](https://osv.dev/vulnerability/GHSA-v26r-4c9c-h3j6)
- <https://crates.io/crates/gix-path>
- <https://rustsec.org/advisories/RUSTSEC-2024-0367.html>
- <https://github.com/Byron/gitoxide/commit/12251eb052df30105538fa831e641eea557f13d8>
- <https://github.com/advisories/GHSA-v26r-4c9c-h3j6>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-45305>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-v26r-4c9c-h3j6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-v26r-4c9c-h3j6/>. Everything for agents: <https://agentprime.io/llms.txt>.
