# Authz zero length regression

Advisory record · `GHSA-v23v-6jw2-98fq`

- **Identifiers:** `GHSA-v23v-6jw2-98fq` · `CVE-2024-41110` · `GO-2024-3005`
- **State:** Confirmed
- **Severity:** CVSS 10.0 Critical
- **Critical:** Yes: CVSS 9+, CVSS 7+ and EPSS
- **Weakness (CWE):** [CWE-187](https://cwe.mitre.org/data/definitions/187.html) · [CWE-444](https://cwe.mitre.org/data/definitions/444.html) · [CWE-863](https://cwe.mitre.org/data/definitions/863.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md) · [Broken access control](https://agentprime.io/advisories/tag/access-control.md) · [CWE-187](https://agentprime.io/advisories/tag/cwe-187.md)
- **Published:** 30 Jul 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Jul 2024, 10:18 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 10.0: 9.0 or more.
- CVSS score 10.0 (7.0 or more) and EPSS 0.16 (0.1 or more): a high score and a real chance of exploitation in the next 30 days.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `github.com/docker/docker` (Go): affected `>=19.03.0, <23.0.15 || >=26.0.0, <26.1.5 || >=27.0.0, <27.1.1 || >=24.0.0, <25.0.6`; fixed in `23.0.15`, `26.1.5`, `27.1.1`, `25.0.6`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Docker Engine (github.com/docker/docker) versions 19.03.0 up to 23.0.15, 24.0.0 up to 25.0.6, 26.0.0 up to 26.1.5, and 27.0.0 up to 27.1.1 are affected. An attacker with access to the Engine API can send a crafted request with Content-Length set to 0 so that an authorization plugin receives it without the body, which may lead it to approve requests it would otherwise deny. Upgrade to 23.0.15, 25.0.6, 26.1.5, 27.1.1, or a later patched release; if you cannot upgrade, avoid AuthZ plugins and restrict Docker API access to trusted parties.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 10.0 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.16, the 97th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:15 UTC: First seen by agentprime
- 31 Oct 2026, 14:15 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-v23v-6jw2-98fq)

## Sources

- [GitHub Advisory Database: GHSA-v23v-6jw2-98fq](https://github.com/advisories/GHSA-v23v-6jw2-98fq)
- [OSV: GHSA-v23v-6jw2-98fq](https://osv.dev/vulnerability/GHSA-v23v-6jw2-98fq)
- <https://github.com/moby/moby/security/advisories/GHSA-v23v-6jw2-98fq>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-41110>
- <https://github.com/moby/moby/commit/411e817ddf710ff8e08fa193da80cb78af708191>
- <https://github.com/moby/moby/commit/42f40b1d6dd7562342f832b9cd2adf9e668eeb76>
- <https://github.com/moby/moby/commit/65cc597cea28cdc25bea3b8a86384b4251872919>
- <https://github.com/moby/moby/commit/852759a7df454cbf88db4e954c919becd48faa9b>
- <https://github.com/moby/moby/commit/a31260625655cff9ae226b51757915e275e304b0>
- <https://github.com/moby/moby/commit/a79fabbfe84117696a19671f4aa88b82d0f64fc1>
- <https://github.com/moby/moby/commit/ae160b4edddb72ef4bd71f66b975a1a1cc434f00>
- <https://github.com/moby/moby/commit/ae2b3666c517c96cbc2adf1af5591a6b00d4ec0f>
- <https://github.com/moby/moby/commit/cc13f952511154a2866bddbb7dddebfe9e83b801>
- <https://github.com/moby/moby/commit/fc274cd2ff4cf3b48c91697fb327dd1fb95588fb>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-v23v-6jw2-98fq>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-v23v-6jw2-98fq/>. Everything for agents: <https://agentprime.io/llms.txt>.
