# Yamcs has Reflected XSS in the URL of the Authorize Endpoint

Advisory record · `GHSA-rxpg-wjf8-qv9c`

- **Identifiers:** `GHSA-rxpg-wjf8-qv9c` · `CVE-2026-55549`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md)
- **Published:** 28 Aug 2026
- **Updated:** 28 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Aug 2026, 17:17 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.yamcs:yamcs-core` (Maven): affected `<5.9.4`; fixed in `5.9.4`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Yamcs (org.yamcs:yamcs-core) versions before 5.9.4 are vulnerable to reflected cross-site scripting in the URL of the authorize endpoint. An attacker can get a user to open a crafted link, which runs arbitrary JavaScript in the user's browser and can expose the user's access and refresh tokens, allowing account takeover. Upgrade to yamcs-core 5.9.4 or later.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.013, the 70th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-rxpg-wjf8-qv9c)

## Sources

- [GitHub Advisory Database: GHSA-rxpg-wjf8-qv9c](https://github.com/advisories/GHSA-rxpg-wjf8-qv9c)
- [OSV: GHSA-rxpg-wjf8-qv9c](https://osv.dev/vulnerability/GHSA-rxpg-wjf8-qv9c)
- <https://github.com/yamcs/yamcs/security/advisories/GHSA-rxpg-wjf8-qv9c>
- <https://github.com/yamcs/yamcs/commit/4d47d5cdcf5d92c2c5bbbc19feada422923332e3>
- <https://github.com/yamcs/yamcs>
- <https://github.com/yamcs/yamcs/releases/tag/yamcs-5.9.4>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-rxpg-wjf8-qv9c>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-rxpg-wjf8-qv9c/>. Everything for agents: <https://agentprime.io/llms.txt>.
