# Decidim::Admin vulnerable to cross-site scripting (XSS) in the admin activity log

Advisory record · `GHSA-rx9f-5ggv-5rh6`

- **Identifiers:** `GHSA-rx9f-5ggv-5rh6` · `CVE-2024-32034`
- **State:** Confirmed
- **Severity:** CVSS 6.8 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md)
- **Published:** 16 Sept 2024
- **Updated:** 17 Sept 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Sept 2024, 17:17 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `decidim-admin` (RubyGems): affected `<0.27.7 || >=0.28.0, <0.28.2`; fixed in `0.27.7`, `0.28.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.8 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0037, the 31st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 16 Sept 2024. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-rx9f-5ggv-5rh6](https://github.com/advisories/GHSA-rx9f-5ggv-5rh6)
- [OSV: GHSA-rx9f-5ggv-5rh6](https://osv.dev/vulnerability/GHSA-rx9f-5ggv-5rh6)
- <https://github.com/decidim/decidim/security/advisories/GHSA-rx9f-5ggv-5rh6>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-32034>
- <https://github.com/decidim/decidim/commit/23fc8d702a4976727f78617f5e42353d67931645>
- <https://github.com/decidim/decidim/commit/9d79f09a2d38c87feb28725670d6cc1f55c22072>
- <https://github.com/decidim/decidim/commit/e494235d559be13dd1f8694345e6f6bba762d1c0>
- <https://github.com/decidim/decidim/commit/ff755e23814aeb56e9089fc08006a5d3faee47b6>
- <https://github.com/decidim/decidim>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim-admin/CVE-2024-32034.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-rx9f-5ggv-5rh6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-rx9f-5ggv-5rh6/>. Everything for agents: <https://agentprime.io/llms.txt>.
