# ExifReader is vulnerable to denial of service via unbounded decompression of image metadata

Advisory record · `GHSA-rr89-w3h9-m66j`

- **Identifiers:** `GHSA-rr89-w3h9-m66j` · `CVE-2026-8814`
- **State:** Confirmed
- **Severity:** CVSS 6.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-409](https://cwe.mitre.org/data/definitions/409.html)
- **Tags:** [CWE-409](https://agentprime.io/advisories/tag/cwe-409.md)
- **Published:** 29 May 2026
- **Updated:** 17 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 29 May 2026, 17:52 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `exifreader` (npm): affected `>=4.20.0, <4.39.0`; fixed in `4.39.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.9 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`, from CNA (snyk)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0046, the 40th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 29 May 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-rr89-w3h9-m66j](https://github.com/advisories/GHSA-rr89-w3h9-m66j)
- [OSV: GHSA-rr89-w3h9-m66j](https://osv.dev/vulnerability/GHSA-rr89-w3h9-m66j)
- <https://github.com/mattiasw/ExifReader/security/advisories/GHSA-rr89-w3h9-m66j>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-8814>
- <https://github.com/mattiasw/ExifReader/commit/5f116128adc19f674902f8bf582bfe7dd0a36375>
- <https://github.com/mattiasw/ExifReader>
- <https://security.snyk.io/vuln/SNYK-JS-EXIFREADER-16689340>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-rr89-w3h9-m66j>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-rr89-w3h9-m66j/>. Everything for agents: <https://agentprime.io/llms.txt>.
