# @Mockoon/commons-server: Unauthenticated admin API + wildcard CORS allows mock-state hijack and secret theft

Advisory record · `GHSA-rqx4-3f6q-3x2v`

- **Identifiers:** `GHSA-rqx4-3f6q-3x2v` · `CVE-2026-59148`
- **State:** Confirmed
- **Severity:** CVSS 8.8 High
- **Critical:** No
- **Weakness (CWE):** [CWE-306](https://cwe.mitre.org/data/definitions/306.html) · [CWE-352](https://cwe.mitre.org/data/definitions/352.html) · [CWE-732](https://cwe.mitre.org/data/definitions/732.html) · [CWE-942](https://cwe.mitre.org/data/definitions/942.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md) · [Cross-site request forgery (CSRF)](https://agentprime.io/advisories/tag/csrf.md) · [Broken access control](https://agentprime.io/advisories/tag/access-control.md) · [CWE-942](https://agentprime.io/advisories/tag/cwe-942.md)
- **Published:** 11 Sept 2026
- **Updated:** 11 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 11 Sept 2026, 22:04 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@mockoon/commons-server` (npm): affected `<9.7.0`; fixed in `9.7.0`
- `@mockoon/cli` (npm): affected `<9.7.0`; fixed in `9.7.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.8 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0026, the 18th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 11 Sept 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-rqx4-3f6q-3x2v](https://github.com/advisories/GHSA-rqx4-3f6q-3x2v)
- [OSV: GHSA-rqx4-3f6q-3x2v](https://osv.dev/vulnerability/GHSA-rqx4-3f6q-3x2v)
- <https://github.com/mockoon/mockoon/security/advisories/GHSA-rqx4-3f6q-3x2v>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-59148>
- <https://github.com/mockoon/mockoon/pull/2254>
- <https://github.com/mockoon/mockoon/commit/c420b5a56918475b8663977b51e5f986e45b3299>
- <https://github.com/mockoon/mockoon>
- <https://github.com/mockoon/mockoon/releases/tag/v9.7.0>
- <https://mockoon.com/releases/9.7.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-rqx4-3f6q-3x2v>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-rqx4-3f6q-3x2v/>. Everything for agents: <https://agentprime.io/llms.txt>.
