# Insufficient Entropy in cryptiles

Advisory record · `GHSA-rq8g-5pc5-wrhr`

- **Identifiers:** `GHSA-rq8g-5pc5-wrhr` · `CVE-2018-1000620`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-331](https://cwe.mitre.org/data/definitions/331.html)
- **Tags:** [CWE-331](https://agentprime.io/advisories/tag/cwe-331.md)
- **Published:** 11 Sept 2018
- **Updated:** 8 Jun 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 11 Sept 2018, 18:22 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `cryptiles` (npm): affected `>=4.0.0, <4.1.2 || >=3.1.0, <3.1.3`; fixed in `4.1.2`, `3.1.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.017, the 77th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 11 Sept 2018. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-rq8g-5pc5-wrhr](https://github.com/advisories/GHSA-rq8g-5pc5-wrhr)
- [OSV: GHSA-rq8g-5pc5-wrhr](https://osv.dev/vulnerability/GHSA-rq8g-5pc5-wrhr)
- <https://nvd.nist.gov/vuln/detail/CVE-2018-1000620>
- <https://github.com/hapijs/cryptiles/issues/34>
- <https://github.com/hapijs/cryptiles/issues/35>
- <https://github.com/hapijs/cryptiles/commit/6bdcd0f6ee8ade96e7b30350bad39ee0c2ef0f9b>
- <https://github.com/hapijs/cryptiles/commit/9332d4263a32b84e76bf538d7470d01ea63fa047>
- <https://github.com/hapijs/cryptiles/commit/cb6bd642816e0cb8341d2b3896fd9e7c57e94f56>
- <https://github.com/hapijs/cryptiles>
- <https://github.com/nodejs/security-wg/blob/master/vuln/npm/476.json>
- <https://www.npmjs.com/advisories/1464>
- <https://www.npmjs.com/advisories/720>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-rq8g-5pc5-wrhr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-rq8g-5pc5-wrhr/>. Everything for agents: <https://agentprime.io/llms.txt>.
