# InventoryGui allows item duplication with experimental "Bundle" item in GUIs which use GuiStorageElement

Advisory record · `GHSA-rgvh-4m82-fvjq`

- **Identifiers:** `GHSA-rgvh-4m82-fvjq` · `CVE-2025-62782`
- **State:** Confirmed
- **Severity:** CVSS 5.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-837](https://cwe.mitre.org/data/definitions/837.html)
- **Tags:** [CWE-837](https://agentprime.io/advisories/tag/cwe-837.md)
- **Published:** 27 Oct 2025
- **Updated:** 27 Oct 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 Oct 2025, 20:12 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `de.themoep:inventorygui` (Maven): affected `<1.6.4-SNAPSHOT`; fixed in `1.6.4-SNAPSHOT`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.9 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:H/VA:L/SC:N/SI:L/SA:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0026, the 17th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:10 UTC: First seen by agentprime
- 31 Oct 2026, 15:10 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-rgvh-4m82-fvjq)

## Sources

- [GitHub Advisory Database: GHSA-rgvh-4m82-fvjq](https://github.com/advisories/GHSA-rgvh-4m82-fvjq)
- [OSV: GHSA-rgvh-4m82-fvjq](https://osv.dev/vulnerability/GHSA-rgvh-4m82-fvjq)
- <https://github.com/Phoenix616/InventoryGui/security/advisories/GHSA-rgvh-4m82-fvjq>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-62782>
- <https://github.com/Phoenix616/InventoryGui/issues/51>
- <https://github.com/Phoenix616/InventoryGui/commit/00e684bd689ebc60bcb5b83ce4ef3c5a01778494>
- <https://github.com/Phoenix616/InventoryGui>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-rgvh-4m82-fvjq>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-rgvh-4m82-fvjq/>. Everything for agents: <https://agentprime.io/llms.txt>.
