# Payload: Insufficient Access Control in Stripe REST Proxy

Advisory record · `GHSA-r9v2-gg2j-22q5`

- **Identifiers:** `GHSA-r9v2-gg2j-22q5` · `CVE-2026-105848`
- **State:** Confirmed
- **Severity:** CVSS 6.4 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-749](https://cwe.mitre.org/data/definitions/749.html) · [CWE-862](https://cwe.mitre.org/data/definitions/862.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md) · [CWE-749](https://agentprime.io/advisories/tag/cwe-749.md)
- **Published:** 6 Oct 2026
- **Updated:** 6 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 6 Oct 2026, 16:09 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@payloadcms/plugin-stripe` (npm): affected `<3.90.0 || >=4.0.0-canary.0, <4.0.0-canary.34`; fixed in `3.90.0`, `4.0.0-canary.34`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Payload's @payloadcms/plugin-stripe package is affected in versions below 3.90.0 and from 4.0.0-canary.0 up to but not including 4.0.0-canary.34. An authenticated user who can reach the optional Stripe REST proxy could perform unintended Stripe operations; deployments without the proxy enabled are not affected. Upgrade to 3.90.0 or 4.0.0-canary.34 or later, or if that is not possible, disable the proxy or restrict it to trusted users and only the Stripe operations they need.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.4 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0024, the 15th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:34 UTC: First seen by agentprime
- 31 Oct 2026, 13:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-r9v2-gg2j-22q5)

## Sources

- [GitHub Advisory Database: GHSA-r9v2-gg2j-22q5](https://github.com/advisories/GHSA-r9v2-gg2j-22q5)
- [OSV: GHSA-r9v2-gg2j-22q5](https://osv.dev/vulnerability/GHSA-r9v2-gg2j-22q5)
- <https://github.com/payloadcms/payload/security/advisories/GHSA-r9v2-gg2j-22q5>
- <https://github.com/payloadcms/payload/commit/2f94a4205e5ba3ec0e91c92ed54f24f429826dd0>
- <https://github.com/payloadcms/payload>
- <https://github.com/payloadcms/payload/releases/tag/v3.90.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-r9v2-gg2j-22q5>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-r9v2-gg2j-22q5/>. Everything for agents: <https://agentprime.io/llms.txt>.
