# \`wasi-http\`: Guests can add conflicting content lengths to messages

Advisory record · `GHSA-r8xh-cgf7-392j`

- **Identifiers:** `GHSA-r8xh-cgf7-392j` · `CVE-2026-121441` · `RUSTSEC-2026-0376`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md)
- **Published:** 19 Oct 2026
- **Updated:** 4 Nov 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 19 Oct 2026, 12:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `wasmtime-wasi-http` (crates.io): affected `>=0.0.0-0, <36.0.19 || >=37.0.0, <48.0.7 || >=49.0.0, <49.0.4`; fixed in `36.0.19`, `48.0.7`, `49.0.4`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The wasmtime-wasi-http crate is vulnerable in versions before 36.0.19, from 37.0.0 before 48.0.7, and from 49.0.0 before 49.0.4. The source gives few details: it is a RustSec entry that points to the GitHub advisory for the full description, and it concerns guests adding conflicting content lengths to messages. Upgrade to 36.0.19, 48.0.7, or 49.0.4 depending on your release line.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0022, the 13th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:24 UTC: First seen by agentprime
- 31 Oct 2026, 14:24 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/RUSTSEC-2026-0376)
- 3 Nov 2026, 14:38 UTC: [Confirmed by the CVE List](https://www.cve.org/CVERecord?id=CVE-2026-121441)
- 3 Nov 2026, 15:25 UTC: [Confirmed by NVD](https://nvd.nist.gov/vuln/detail/CVE-2026-121441)

## Sources

- [GitHub Advisory Database: GHSA-r8xh-cgf7-392j](https://github.com/advisories/GHSA-r8xh-cgf7-392j)
- [OSV: GHSA-r8xh-cgf7-392j](https://osv.dev/vulnerability/GHSA-r8xh-cgf7-392j)
- <https://crates.io/crates/wasmtime-wasi-http>
- <https://rustsec.org/advisories/RUSTSEC-2026-0376.html>
- <https://github.com/bytecodealliance/wasmtime/pull/14824>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-r8xh-cgf7-392j>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-r8xh-cgf7-392j/>. Everything for agents: <https://agentprime.io/llms.txt>.
