# Parse Server vulnerable to stored XSS via malformed Content-Type bypassing file upload extension blocklist

Advisory record · `GHSA-r899-h629-j84r`

- **Identifiers:** `GHSA-r899-h629-j84r` · `BIT-parse-2026-61448` · `CVE-2026-61448`
- **State:** Confirmed
- **Severity:** CVSS 2.1 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-434](https://cwe.mitre.org/data/definitions/434.html)
- **Tags:** [Unrestricted file upload](https://agentprime.io/advisories/tag/file-upload.md)
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 29 Oct 2026, 16:33 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `parse-server` (npm): affected `>=9.0.0, <9.10.0-alpha.2 || <8.6.84`; fixed in `9.10.0-alpha.2`, `8.6.84`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Parse Server, the npm package parse-server, versions below 8.6.84 and from 9.0.0 up to but not including 9.10.0-alpha.2, has a stored cross-site scripting flaw in its file upload handling. A malformed Content-Type on an uploaded file bypassed the extension blocklist, and on storage adapters that persist that header, such as Amazon S3, Google Cloud Storage, or Azure Blob Storage, a user permitted to upload files can store HTML-with-script that runs against other users who open the file URL. Upgrade to parse-server 8.6.84 or 9.10.0-alpha.2 or later, which reject malformed Content-Type values.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.1 Low, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0042, the 35th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:32 UTC: First seen by agentprime
- 31 Oct 2026, 13:32 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-r899-h629-j84r)

## Sources

- [GitHub Advisory Database: GHSA-r899-h629-j84r](https://github.com/advisories/GHSA-r899-h629-j84r)
- [OSV: GHSA-r899-h629-j84r](https://osv.dev/vulnerability/GHSA-r899-h629-j84r)
- <https://github.com/parse-community/parse-server/security/advisories/GHSA-r899-h629-j84r>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-61448>
- <https://github.com/parse-community/parse-server>
- <https://www.vulncheck.com/advisories/parse-server-stored-xss-via-malformed-content-type>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-r899-h629-j84r>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-r899-h629-j84r/>. Everything for agents: <https://agentprime.io/llms.txt>.
