# phpseclib has a variable-time HMAC comparison in SSH2::get_binary_packet() using != instead of hash_equals()

Advisory record · `GHSA-r854-jrxh-36qx`

- **Identifiers:** `GHSA-r854-jrxh-36qx` · `CVE-2026-40194` · `PKSA-zh4j-by9m-7mz8`
- **State:** Confirmed
- **Severity:** CVSS 3.7 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-208](https://cwe.mitre.org/data/definitions/208.html)
- **Tags:** [CWE-208](https://agentprime.io/advisories/tag/cwe-208.md)
- **Published:** 10 Apr 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 10 Apr 2026, 20:58 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `phpseclib/phpseclib` (Packagist): affected `>=0.1.1, <1.0.28 || >=2.0.0, <2.0.53 || >=3.0.0, <3.0.51`; fixed in `1.0.28`, `2.0.53`, `3.0.51`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> phpseclib versions below 1.0.28, from 2.0.0 below 2.0.53, and from 3.0.0 below 3.0.51 compare SSH2 packet HMACs with PHP's != operator in SSH2::get_binary_packet(), a comparison that can run in variable time. The source describes this as a low-severity, defense-in-depth issue and says that practical network exploitation is prevented by the protocol's disconnect-on-MAC-failure behavior and per-connection keys. Upgrade to phpseclib 1.0.28, 2.0.53, or 3.0.51, which replace the comparison with hash_equals().

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.7 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0036, the 30th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:59 UTC: First seen by agentprime
- 31 Oct 2026, 13:59 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-r854-jrxh-36qx)

## Sources

- [GitHub Advisory Database: GHSA-r854-jrxh-36qx](https://github.com/advisories/GHSA-r854-jrxh-36qx)
- [OSV: GHSA-r854-jrxh-36qx](https://osv.dev/vulnerability/GHSA-r854-jrxh-36qx)
- <https://github.com/phpseclib/phpseclib/security/advisories/GHSA-r854-jrxh-36qx>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-40194>
- <https://github.com/phpseclib/phpseclib/commit/ffe48b6b1b1af6963327f0a5330e3aa004a194ac>
- <https://github.com/phpseclib/phpseclib>
- <https://github.com/phpseclib/phpseclib/releases/tag/1.0.28>
- <https://github.com/phpseclib/phpseclib/releases/tag/2.0.53>
- <https://github.com/phpseclib/phpseclib/releases/tag/3.0.51>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-r854-jrxh-36qx>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-r854-jrxh-36qx/>. Everything for agents: <https://agentprime.io/llms.txt>.
