# GraphQL-core: Denial of service via comment tokens bypassing the parser's max_tokens limit

Advisory record · `GHSA-r77w-qph3-7vf8`

- **Identifiers:** `GHSA-r77w-qph3-7vf8` · `CVE-2026-75508`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-400](https://cwe.mitre.org/data/definitions/400.html) · [CWE-770](https://cwe.mitre.org/data/definitions/770.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 22 Oct 2026
- **Updated:** 22 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 Oct 2026, 16:27 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `graphql-core` (PyPI): affected `>=3.2.3, <3.2.12 || >=3.3.0a3, <3.3.0rc1`; fixed in `3.2.12`, `3.3.0rc1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> GraphQL-core versions 3.2.3 before 3.2.12 and 3.3.0a3 before 3.3.0rc1 are vulnerable to denial of service, because the parser's max_tokens limit did not count comment tokens. An unauthenticated attacker can send a comment-padded GraphQL document that passes the limit while still allocating a large number of token objects, which can exhaust memory. Upgrade to 3.2.12 or 3.3.0rc1. Comments now count toward max_tokens, so documents with many comments may need a higher limit.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0057, the 47th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:08 UTC: First seen by agentprime
- 31 Oct 2026, 14:08 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-r77w-qph3-7vf8)

## Sources

- [GitHub Advisory Database: GHSA-r77w-qph3-7vf8](https://github.com/advisories/GHSA-r77w-qph3-7vf8)
- [OSV: GHSA-r77w-qph3-7vf8](https://osv.dev/vulnerability/GHSA-r77w-qph3-7vf8)
- <https://github.com/graphql-python/graphql-core/security/advisories/GHSA-r77w-qph3-7vf8>
- <https://github.com/graphql-python/graphql-core/commit/437dea102e92fdf05a2971ca76787c5a5bad875a>
- <https://github.com/graphql-python/graphql-core/commit/80ef435a1808fbbcc4aaac63ae76771a1c91002d>
- <https://github.com/graphql-python/graphql-core>
- <https://github.com/graphql-python/graphql-core/releases/tag/v3.2.12>
- <https://github.com/graphql-python/graphql-core/releases/tag/v3.3.0rc1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-r77w-qph3-7vf8>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-r77w-qph3-7vf8/>. Everything for agents: <https://agentprime.io/llms.txt>.
