# Jenkins has a link following vulnerability allows arbitrary file creation

Advisory record · `GHSA-r6qv-frpc-q66c`

- **Identifiers:** `GHSA-r6qv-frpc-q66c` · `BIT-jenkins-2026-33001` · `CVE-2026-33001`
- **State:** Confirmed
- **Severity:** CVSS 8.8 High
- **Critical:** No
- **Weakness (CWE):** [CWE-22](https://cwe.mitre.org/data/definitions/22.html) · [CWE-59](https://cwe.mitre.org/data/definitions/59.html) · [CWE-61](https://cwe.mitre.org/data/definitions/61.html)
- **Tags:** [Path traversal](https://agentprime.io/advisories/tag/path-traversal.md) · [CWE-61](https://agentprime.io/advisories/tag/cwe-61.md)
- **Published:** 18 Mar 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 18 Mar 2026, 18:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.jenkins-ci.main:jenkins-core` (Maven): affected `<2.555`; fixed in `2.555`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Jenkins core (Maven org.jenkins-ci.main:jenkins-core) versions before 2.555 are vulnerable, including 2.554 and earlier and LTS 2.541.2 and earlier. Its handling of symbolic links while extracting .tar and .tar.gz archives is unsafe, so a crafted archive can write files to arbitrary locations. An attacker with Item/Configure permission, or control of agent processes, can use this to deploy malicious scripts or plugins on the controller. Upgrade jenkins-core to version 2.555.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.8 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.021, the 81st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:17 UTC: First seen by agentprime
- 31 Oct 2026, 14:17 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-r6qv-frpc-q66c)

## Sources

- [GitHub Advisory Database: GHSA-r6qv-frpc-q66c](https://github.com/advisories/GHSA-r6qv-frpc-q66c)
- [OSV: GHSA-r6qv-frpc-q66c](https://osv.dev/vulnerability/GHSA-r6qv-frpc-q66c)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-33001>
- <https://github.com/jenkinsci/jenkins/commit/6dc99937605d5bddfeaae43a4cd14c2571e23adc>
- <https://github.com/jenkinsci/jenkins>
- <https://github.com/jenkinsci/jenkins/releases/tag/jenkins-2.555>
- <https://www.jenkins.io/security/advisory/2026-03-18/#SECURITY-3657>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-r6qv-frpc-q66c>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-r6qv-frpc-q66c/>. Everything for agents: <https://agentprime.io/llms.txt>.
