# cryptography Vulnerable to a Subgroup Attack Due to Missing Subgroup Validation for SECT Curves

Advisory record · `GHSA-r6ph-v2qm-q3c2`

- **Identifiers:** `GHSA-r6ph-v2qm-q3c2` · `CVE-2026-26007` · `PYSEC-2026-2141`
- **State:** Confirmed
- **Severity:** CVSS 8.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-345](https://cwe.mitre.org/data/definitions/345.html) · [CWE-354](https://cwe.mitre.org/data/definitions/354.html)
- **Tags:** [CWE-345](https://agentprime.io/advisories/tag/cwe-345.md) · [CWE-354](https://agentprime.io/advisories/tag/cwe-354.md)
- **Published:** 10 Feb 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 10 Feb 2026, 21:27 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `cryptography` (PyPI): affected `<46.0.5`; fixed in `46.0.5`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The cryptography Python package before 46.0.5 does not check that elliptic curve public key points lie in the prime-order subgroup, but only SECT curves are affected. An attacker who can supply a public key, for example to a service that loads it, can leak information about a victim's private key during ECDH and forge ECDSA signatures on the small subgroup. Upgrade cryptography to version 46.0.5 or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.2 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0039, the 33rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:11 UTC: First seen by agentprime
- 31 Oct 2026, 14:11 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-r6ph-v2qm-q3c2)

## Sources

- [GitHub Advisory Database: GHSA-r6ph-v2qm-q3c2](https://github.com/advisories/GHSA-r6ph-v2qm-q3c2)
- [OSV: GHSA-r6ph-v2qm-q3c2](https://osv.dev/vulnerability/GHSA-r6ph-v2qm-q3c2)
- <https://github.com/pyca/cryptography/security/advisories/GHSA-r6ph-v2qm-q3c2>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-26007>
- <https://github.com/pyca/cryptography/commit/0eebb9dbb6343d9bc1d91e5a2482ed4e054a6d8c>
- <https://github.com/pyca/cryptography>
- <https://github.com/pyca/cryptography/releases/tag/46.0.5>
- <http://www.openwall.com/lists/oss-security/2026/02/10/4>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-r6ph-v2qm-q3c2>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-r6ph-v2qm-q3c2/>. Everything for agents: <https://agentprime.io/llms.txt>.
