# Wagtail: Improper permission handling in image preview

Advisory record · `GHSA-r6p4-grq7-xm4m`

- **Identifiers:** `GHSA-r6p4-grq7-xm4m` · `CVE-2026-54261` · `PYSEC-2026-614`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-280](https://cwe.mitre.org/data/definitions/280.html)
- **Tags:** [CWE-280](https://agentprime.io/advisories/tag/cwe-280.md)
- **Published:** 20 Aug 2026
- **Updated:** 20 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Aug 2026, 18:40 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `wagtail` (PyPI): affected `<7.0.8 || >=7.1, <7.3.3 || >=7.4, <7.4.2`; fixed in `7.0.8`, `7.3.3`, `7.4.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Wagtail versions before 7.0.8, from 7.1 before 7.3.3, and from 7.4 before 7.4.2 are affected. A user with access to the Wagtail admin can preview any image because of a missing permission check, though the image's stored data is not exposed and ordinary site visitors cannot exploit it. Upgrade to Wagtail 7.0.8, 7.3.3, or 7.4.2; sites that cannot upgrade can override the vulnerable view through a urls.py change described in the advisory.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0034, the 27th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:39 UTC: First seen by agentprime
- 31 Oct 2026, 14:39 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-r6p4-grq7-xm4m)

## Sources

- [GitHub Advisory Database: GHSA-r6p4-grq7-xm4m](https://github.com/advisories/GHSA-r6p4-grq7-xm4m)
- [OSV: GHSA-r6p4-grq7-xm4m](https://osv.dev/vulnerability/GHSA-r6p4-grq7-xm4m)
- <https://github.com/wagtail/wagtail/security/advisories/GHSA-r6p4-grq7-xm4m>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-54261>
- <https://github.com/pypa/advisory-database/tree/main/vulns/wagtail/PYSEC-2026-614.yaml>
- <https://github.com/wagtail/wagtail>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-r6p4-grq7-xm4m>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-r6p4-grq7-xm4m/>. Everything for agents: <https://agentprime.io/llms.txt>.
