# Potential DoS when using ContextLines integration

Advisory record · `GHSA-r5w7-f542-q2j4`

- **Identifiers:** `GHSA-r5w7-f542-q2j4`
- **State:** Confirmed
- **Severity:** CVSS 3.7 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-774](https://cwe.mitre.org/data/definitions/774.html)
- **Tags:** [CWE-774](https://agentprime.io/advisories/tag/cwe-774.md)
- **Published:** 28 Jan 2025
- **Updated:** 28 Jan 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Jan 2025, 20:37 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@sentry/node` (npm): affected `>=8.10.0, <8.49.0`; fixed in `8.49.0`
- `@sentry/astro` (npm): affected `>=8.10.0, <8.49.0`; fixed in `8.49.0`
- `@sentry/aws-serverless` (npm): affected `>=8.10.0, <8.49.0`; fixed in `8.49.0`
- `@sentry/bun` (npm): affected `>=8.10.0, <8.49.0`; fixed in `8.49.0`
- `@sentry/google-cloud-serverless` (npm): affected `>=8.10.0, <8.49.0`; fixed in `8.49.0`
- `@sentry/nestjs` (npm): affected `>=8.10.0, <8.49.0`; fixed in `8.49.0`
- `@sentry/nextjs` (npm): affected `>=8.10.0, <8.49.0`; fixed in `8.49.0`
- `@sentry/nuxt` (npm): affected `>=8.10.0, <8.49.0`; fixed in `8.49.0`
- `@sentry/remix` (npm): affected `>=8.10.0, <8.49.0`; fixed in `8.49.0`
- `@sentry/solidstart` (npm): affected `>=8.10.0, <8.49.0`; fixed in `8.49.0`
- `@sentry/sveltekit` (npm): affected `>=8.10.0, <8.49.0`; fixed in `8.49.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.7 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 28 Jan 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-r5w7-f542-q2j4](https://github.com/advisories/GHSA-r5w7-f542-q2j4)
- [OSV: GHSA-r5w7-f542-q2j4](https://osv.dev/vulnerability/GHSA-r5w7-f542-q2j4)
- <https://github.com/getsentry/sentry-javascript/security/advisories/GHSA-r5w7-f542-q2j4>
- <https://github.com/getsentry/sentry-javascript/issues/14892>
- <https://github.com/getsentry/sentry-javascript/pull/14997>
- <https://github.com/getsentry/sentry-javascript>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-r5w7-f542-q2j4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-r5w7-f542-q2j4/>. Everything for agents: <https://agentprime.io/llms.txt>.
