# Duplicate Advisory: Nokogiri updates packaged libxml2 to v2.12.7 to resolve CVE-2024-34459

Advisory record · `GHSA-r3w4-36x6-7r99` · Withdrawn

- **Identifiers:** `GHSA-r3w4-36x6-7r99`
- **State:** Withdrawn
- **Severity:** No CVSS score
- **Critical:** No
- **Weakness (CWE):** [CWE-119](https://cwe.mitre.org/data/definitions/119.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md)
- **Published:** 14 May 2024
- **Updated:** 7 Aug 2026
- **Reviewed by a person:** No

**Withdrawn.** The GitHub Advisory Database withdrew this advisory on 16 May 2024. The record stays here, marked withdrawn.

Published by the GitHub Advisory Database at 14 May 2024, 22:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `nokogiri` (RubyGems): affected `<1.16.5`; fixed in `1.16.5`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

No source has published a CVSS score for this record yet.

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-r3w4-36x6-7r99)

## Sources

- [GitHub Advisory Database: GHSA-r3w4-36x6-7r99](https://github.com/advisories/GHSA-r3w4-36x6-7r99)
- [OSV: GHSA-r3w4-36x6-7r99](https://osv.dev/vulnerability/GHSA-r3w4-36x6-7r99)
- <https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-r95h-9x8f-r3f7>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/GHSA-r95h-9x8f-r3f7.yml>
- <https://github.com/sparklemotion/nokogiri>
- <https://gitlab.gnome.org/GNOME/libxml2/-/issues/720>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-r3w4-36x6-7r99>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-r3w4-36x6-7r99/>. Everything for agents: <https://agentprime.io/llms.txt>.
