# ruby-saml vulnerable to XPath injection

Advisory record · `GHSA-r364-2pj4-pf7f`

- **Identifiers:** `GHSA-r364-2pj4-pf7f` · `CVE-2015-20108`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-77](https://cwe.mitre.org/data/definitions/77.html)
- **Tags:** [Command injection](https://agentprime.io/advisories/tag/command-injection.md)
- **Published:** 27 May 2023
- **Updated:** 14 Jan 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 May 2023, 21:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `ruby-saml` (RubyGems): affected `<1.0.0`; fixed in `1.0.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.013, the 71st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 27 May 2023. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-r364-2pj4-pf7f](https://github.com/advisories/GHSA-r364-2pj4-pf7f)
- [OSV: GHSA-r364-2pj4-pf7f](https://osv.dev/vulnerability/GHSA-r364-2pj4-pf7f)
- <https://nvd.nist.gov/vuln/detail/CVE-2015-20108>
- <https://github.com/SAML-Toolkits/ruby-saml/pull/225>
- <https://github.com/SAML-Toolkits/ruby-saml/commit/9853651b96b99653ea8627d757d46bfe62ab6448>
- <https://github.com/SAML-Toolkits/ruby-saml>
- <https://github.com/SAML-Toolkits/ruby-saml/compare/v0.9.2...v1.0.0>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/CVE-2015-20108.yml>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/OSVDB-124991.yml>
- <https://security.netapp.com/advisory/ntap-20230703-0003>
- <https://security.snyk.io/vuln/SNYK-RUBY-RUBYSAML-20217>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-r364-2pj4-pf7f>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-r364-2pj4-pf7f/>. Everything for agents: <https://agentprime.io/llms.txt>.
