# HTTP Proxy bypass using IPv6 Zone IDs in golang.org/x/net

Advisory record · `GHSA-qxp5-gwg8-xv66`

- **Identifiers:** `GHSA-qxp5-gwg8-xv66` · `CVE-2025-22870` · `GO-2025-3503`
- **State:** Confirmed
- **Severity:** CVSS 4.4 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-115](https://cwe.mitre.org/data/definitions/115.html)
- **Tags:** [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md) · [CWE-115](https://agentprime.io/advisories/tag/cwe-115.md)
- **Published:** 12 Mar 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 12 Mar 2025, 22:06 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `golang.org/x/net` (Go): affected `<0.36.0`; fixed in `0.36.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The golang.org/x/net package is vulnerable in versions before 0.36.0. When hosts are matched against proxy patterns, an IPv6 zone ID can be wrongly treated as part of the hostname, so a request can skip the proxy it should have used. An attacker who can make requests through the affected code could cause traffic to bypass the configured proxy. Upgrade to golang.org/x/net 0.36.0 or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.4 Medium, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0043, the 36th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:15 UTC: First seen by agentprime
- 31 Oct 2026, 14:15 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-qxp5-gwg8-xv66)

## Sources

- [GitHub Advisory Database: GHSA-qxp5-gwg8-xv66](https://github.com/advisories/GHSA-qxp5-gwg8-xv66)
- [OSV: GHSA-qxp5-gwg8-xv66](https://osv.dev/vulnerability/GHSA-qxp5-gwg8-xv66)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-22870>
- <https://go-review.googlesource.com/q/project:net>
- <https://go.dev/cl/654697>
- <https://go.dev/issue/71984>
- <https://groups.google.com/g/golang-announce/c/4t3lzH3I0eI/m/b42ImqrBAQAJ>
- <https://pkg.go.dev/vuln/GO-2025-3503>
- <https://security.netapp.com/advisory/ntap-20250509-0007>
- <http://www.openwall.com/lists/oss-security/2025/03/07/2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-qxp5-gwg8-xv66>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-qxp5-gwg8-xv66/>. Everything for agents: <https://agentprime.io/llms.txt>.
