# Apache Camel: KeycloakSecurityPolicy has Improper Authentication, Missing Authentication for Critical Function and Failing Open Vulnerabilities

Advisory record · `GHSA-qvc3-6q9x-95pj`

- **Identifiers:** `GHSA-qvc3-6q9x-95pj` · `CVE-2026-53913`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-287](https://cwe.mitre.org/data/definitions/287.html) · [CWE-306](https://cwe.mitre.org/data/definitions/306.html) · [CWE-636](https://cwe.mitre.org/data/definitions/636.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md) · [CWE-636](https://agentprime.io/advisories/tag/cwe-636.md)
- **Published:** 6 Jul 2026
- **Updated:** 24 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 6 Jul 2026, 09:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `org.apache.camel:camel-keycloak` (Maven): affected `>=4.15.0, <4.18.3 || >=4.19.0, <4.21.0`; fixed in `4.18.3`, `4.21.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.011, the 65th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-qvc3-6q9x-95pj)

## Sources

- [GitHub Advisory Database: GHSA-qvc3-6q9x-95pj](https://github.com/advisories/GHSA-qvc3-6q9x-95pj)
- [OSV: GHSA-qvc3-6q9x-95pj](https://osv.dev/vulnerability/GHSA-qvc3-6q9x-95pj)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-53913>
- <https://github.com/apache/camel/commit/1477cb4e87b2c301f1cdcddca5b153fbbef6934b>
- <https://camel.apache.org/security/CVE-2026-53913.html>
- <https://github.com/apache/camel>
- <https://issues.apache.org/jira/browse/CAMEL-23738>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-qvc3-6q9x-95pj>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-qvc3-6q9x-95pj/>. Everything for agents: <https://agentprime.io/llms.txt>.
