# zebrad has full node denial of service via non-ASCII LongPollId in getblocktemplate

Advisory record · `GHSA-qv2r-v3mx-f4pf`

- **Identifiers:** `GHSA-qv2r-v3mx-f4pf` · `CVE-2026-52731`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-248](https://cwe.mitre.org/data/definitions/248.html)
- **Tags:** [CWE-248](https://agentprime.io/advisories/tag/cwe-248.md)
- **Published:** 2 Jul 2026
- **Updated:** 2 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 2 Jul 2026, 19:28 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `zebra-rpc` (crates.io): affected `<8.0.0`; fixed in `8.0.0`
- `zebrad` (crates.io): affected `<4.5.0`; fixed in `4.5.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0053, the 44th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:18 UTC: First seen by agentprime
- 31 Oct 2026, 15:18 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-qv2r-v3mx-f4pf)

## Sources

- [GitHub Advisory Database: GHSA-qv2r-v3mx-f4pf](https://github.com/advisories/GHSA-qv2r-v3mx-f4pf)
- [OSV: GHSA-qv2r-v3mx-f4pf](https://osv.dev/vulnerability/GHSA-qv2r-v3mx-f4pf)
- <https://github.com/ZcashFoundation/zebra/security/advisories/GHSA-qv2r-v3mx-f4pf>
- <https://github.com/ZcashFoundation/zebra>
- <https://github.com/ZcashFoundation/zebra/blob/d4cd662c716382f6397d2a730148025a1ca79fec/Cargo.toml#L305>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-qv2r-v3mx-f4pf>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-qv2r-v3mx-f4pf/>. Everything for agents: <https://agentprime.io/llms.txt>.
