# Ghost: Authorization Bypass in Comment Like Feature

Advisory record · `GHSA-qrh6-cwg3-343x`

- **Identifiers:** `GHSA-qrh6-cwg3-343x` · `BIT-ghost-2026-103288` · `CVE-2026-103288`
- **State:** Confirmed
- **Severity:** CVSS 7.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-639](https://cwe.mitre.org/data/definitions/639.html) · [CWE-943](https://cwe.mitre.org/data/definitions/943.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md) · [Other injection](https://agentprime.io/advisories/tag/injection.md)
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 Oct 2026, 14:44 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `ghost` (npm): affected `>=5.9.0, <6.44.1`; fixed in `6.44.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Ghost versions from 5.9.0 up to 6.44.1 are affected by an authorization bypass in the comment like feature, caused by an input validation issue. A member with an account can delete comment likes or dislikes they are not authorized to remove. Upgrade Ghost to version 6.44.1 or later, which contains the fix; Docker and Ghost-CLI update instructions are linked in the source.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.1 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0020, the 10th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-qrh6-cwg3-343x)

## Sources

- [GitHub Advisory Database: GHSA-qrh6-cwg3-343x](https://github.com/advisories/GHSA-qrh6-cwg3-343x)
- [OSV: GHSA-qrh6-cwg3-343x](https://osv.dev/vulnerability/GHSA-qrh6-cwg3-343x)
- <https://github.com/TryGhost/Ghost/security/advisories/GHSA-qrh6-cwg3-343x>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-103288>
- <https://github.com/TryGhost/Ghost/pull/28297>
- <https://github.com/TryGhost/Ghost/commit/405c2623ff9060295d4a87d3a0eb4ef766c8d2d3>
- <https://github.com/TryGhost/Ghost>
- <https://github.com/TryGhost/Ghost/releases/tag/v6.44.1>
- <https://www.vulncheck.com/advisories/ghost-5.9.0-before-6.44.1-authorization-bypass-via-comment-like>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-qrh6-cwg3-343x>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-qrh6-cwg3-343x/>. Everything for agents: <https://agentprime.io/llms.txt>.
