# An issue was discovered in Django 5.2 before 5.2.15 and 6.0 before 6.0.6.

Advisory record · `GHSA-qpc8-7fxc-cm4p`

- **Identifiers:** `GHSA-qpc8-7fxc-cm4p` · `BIT-django-2026-35193` · `CVE-2026-35193` · `PYSEC-2026-197`
- **State:** Confirmed
- **Severity:** CVSS 2.3 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-524](https://cwe.mitre.org/data/definitions/524.html)
- **Tags:** [CWE-524](https://agentprime.io/advisories/tag/cwe-524.md)
- **Published:** 3 Jun 2026
- **Updated:** 10 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 3 Jun 2026, 14:16 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `django` (PyPI): affected `>=5.2, <5.2.15 || >=6.0, <6.0.6`; fixed in `5.2.15`, `6.0.6`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Django versions 5.2 before 5.2.15 and 6.0 before 6.0.6 are affected. UpdateCacheMiddleware does not add Authorization to the Vary response header for requests that carry that header without Cache-Control: public, so a remote attacker making unauthenticated requests to the same URL can read private cached responses. Upgrade to Django 5.2.15 or 6.0.6. Earlier unsupported series were not evaluated and may also be affected.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.3 Low, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`, from CNA (DSF)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0037, the 31st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:40 UTC: First seen by agentprime
- 31 Oct 2026, 14:40 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/PYSEC-2026-197)

## Sources

- [GitHub Advisory Database: GHSA-qpc8-7fxc-cm4p](https://github.com/advisories/GHSA-qpc8-7fxc-cm4p)
- [OSV: GHSA-qpc8-7fxc-cm4p](https://osv.dev/vulnerability/GHSA-qpc8-7fxc-cm4p)
- <https://groups.google.com/g/django-announce>
- <https://docs.djangoproject.com/en/dev/releases/security/>
- <https://www.djangoproject.com/weblog/2026/jun/03/security-releases/>
- <https://github.com/advisories/GHSA-qpc8-7fxc-cm4p>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-qpc8-7fxc-cm4p>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-qpc8-7fxc-cm4p/>. Everything for agents: <https://agentprime.io/llms.txt>.
