# sinatra does not validate expanded path matches

Advisory record · `GHSA-qp49-3pvw-x4m5`

- **Identifiers:** `GHSA-qp49-3pvw-x4m5` · `CVE-2022-29970`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-22](https://cwe.mitre.org/data/definitions/22.html) · [CWE-426](https://cwe.mitre.org/data/definitions/426.html)
- **Tags:** [Path traversal](https://agentprime.io/advisories/tag/path-traversal.md) · [CWE-426](https://agentprime.io/advisories/tag/cwe-426.md)
- **Published:** 3 May 2022
- **Updated:** 4 Nov 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 3 May 2022, 00:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `sinatra` (RubyGems): affected `<2.2.0`; fixed in `2.2.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.021, the 82nd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 3 May 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-qp49-3pvw-x4m5](https://github.com/advisories/GHSA-qp49-3pvw-x4m5)
- [OSV: GHSA-qp49-3pvw-x4m5](https://osv.dev/vulnerability/GHSA-qp49-3pvw-x4m5)
- <https://nvd.nist.gov/vuln/detail/CVE-2022-29970>
- <https://github.com/sinatra/sinatra/pull/1683>
- <https://github.com/sinatra/sinatra/pull/1683/commits/462c3ca1db53ed3cfc394cf5948e9c948ad1c10e>
- <https://github.com/skylightio/skylight-ruby/pull/294>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/sinatra/CVE-2022-29970.yml>
- <https://github.com/sinatra/sinatra>
- <https://lists.debian.org/debian-lts-announce/2022/10/msg00034.html>
- <https://lists.debian.org/debian-lts-announce/2024/09/msg00020.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-qp49-3pvw-x4m5>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-qp49-3pvw-x4m5/>. Everything for agents: <https://agentprime.io/llms.txt>.
