# Passbolt Api Tabnabbing when opening URI with menu "Open URI in a new tab"

Advisory record · `GHSA-qm5v-pj64-852j`

- **Identifiers:** `GHSA-qm5v-pj64-852j` · `PKSA-kr8c-3bqr-5ndv`
- **State:** Confirmed
- **Severity:** CVSS 5.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-657](https://cwe.mitre.org/data/definitions/657.html)
- **Tags:** [CWE-657](https://agentprime.io/advisories/tag/cwe-657.md)
- **Published:** 20 May 2024
- **Updated:** 5 Dec 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 May 2024, 17:09 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `passbolt/passbolt_api` (Packagist): affected `<2.11.0`; fixed in `2.11.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Passbolt API versions before 2.11.0 are vulnerable to tabnabbing: a user can be sent a resource containing a malicious URI, and when the victim opens it with "Open URI in a new tab", the opened page can access the opener window. An attacker who can share a resource with the victim could use this to redirect the original tab to a phishing page or call application scripts on the user's behalf. Upgrade passbolt_api to version 2.11.0 or later.

Written 4 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:28 UTC: First seen by agentprime
- 31 Oct 2026, 14:28 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-qm5v-pj64-852j)

## Sources

- [GitHub Advisory Database: GHSA-qm5v-pj64-852j](https://github.com/advisories/GHSA-qm5v-pj64-852j)
- [OSV: GHSA-qm5v-pj64-852j](https://osv.dev/vulnerability/GHSA-qm5v-pj64-852j)
- <https://github.com/passbolt/passbolt_api/commit/f568e113beb3134446eda9e66400d28d726ee20d>
- <https://github.com/FriendsOfPHP/security-advisories/blob/master/passbolt/passbolt_api/2019-08-07-3.yaml>
- <https://github.com/passbolt/passbolt_api>
- <https://www.passbolt.com/incidents/20190807_multiple_vulnerabilities>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-qm5v-pj64-852j>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-qm5v-pj64-852j/>. Everything for agents: <https://agentprime.io/llms.txt>.
