# XWiki Platform Old Core: Resource path traversal via /skin/ action endpoint in Jetty 12+

Advisory record · `GHSA-qj4x-9g63-25g6`

- **Identifiers:** `GHSA-qj4x-9g63-25g6` · `CVE-2026-34151`
- **State:** Confirmed
- **Severity:** CVSS 8.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-24](https://cwe.mitre.org/data/definitions/24.html)
- **Tags:** [Path traversal](https://agentprime.io/advisories/tag/path-traversal.md)
- **Published:** 7 Jul 2026
- **Updated:** 7 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 7 Jul 2026, 13:01 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.xwiki.platform:xwiki-platform-oldcore` (Maven): affected `<17.10.5 || >=18.0.0-rc-1, <18.2.0`; fixed in `17.10.5`, `18.2.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The XWiki Platform Old Core package (Maven org.xwiki.platform:xwiki-platform-oldcore) is vulnerable to path traversal through the /skin/ action endpoint when running on Jetty 12 or later, in versions before 17.10.5 and from 18.0.0-rc-1 before 18.2.0. A remote attacker can craft a URL to read files that the Jetty process is permitted to access, including XWiki configuration files. Upgrade to 17.10.5 or 18.2.0. Running XWiki on Jetty below version 12 or on Tomcat is reported as not affected.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.2 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.025, the 84th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:20 UTC: First seen by agentprime
- 31 Oct 2026, 14:20 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-qj4x-9g63-25g6)

## Sources

- [GitHub Advisory Database: GHSA-qj4x-9g63-25g6](https://github.com/advisories/GHSA-qj4x-9g63-25g6)
- [OSV: GHSA-qj4x-9g63-25g6](https://osv.dev/vulnerability/GHSA-qj4x-9g63-25g6)
- <https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-qj4x-9g63-25g6>
- <https://github.com/xwiki/xwiki-commons/pull/1675>
- <https://github.com/xwiki/xwiki-platform>
- <https://jira.xwiki.org/browse/XCOMMONS-3594>
- <https://jira.xwiki.org/browse/XWIKI-24075>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-qj4x-9g63-25g6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-qj4x-9g63-25g6/>. Everything for agents: <https://agentprime.io/llms.txt>.
