# Eclipse Jetty URI parsing of invalid authority

Advisory record · `GHSA-qh8g-58pp-2wxh`

- **Identifiers:** `GHSA-qh8g-58pp-2wxh` · `CVE-2024-6763`
- **State:** Confirmed
- **Severity:** CVSS 3.7 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-1286](https://cwe.mitre.org/data/definitions/1286.html)
- **Tags:** [CWE-1286](https://agentprime.io/advisories/tag/cwe-1286.md)
- **Published:** 14 Oct 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 Oct 2024, 21:11 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.eclipse.jetty:jetty-http` (Maven): affected `>=7.0.0, <12.0.12`; fixed in `12.0.12`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Jetty's jetty-http package (org.eclipse.jetty:jetty-http) versions 7.0.0 up to 12.0.12 are affected. The HttpURI utility class, when used directly by an application, accepts malformed URIs with unvalidated authority sections and may extract a different host than a browser does. An attacker who can supply such a URI could bypass host blocklists, enabling open redirect or server-side request forgery, when combined with a vulnerable browser. Upgrade to version 12.0.12, which fully validates URI authority characters.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.7 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`, from CNA (eclipse)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0097, the 61st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:17 UTC: First seen by agentprime
- 31 Oct 2026, 14:17 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-qh8g-58pp-2wxh)

## Sources

- [GitHub Advisory Database: GHSA-qh8g-58pp-2wxh](https://github.com/advisories/GHSA-qh8g-58pp-2wxh)
- [OSV: GHSA-qh8g-58pp-2wxh](https://osv.dev/vulnerability/GHSA-qh8g-58pp-2wxh)
- <https://github.com/jetty/jetty.project/security/advisories/GHSA-qh8g-58pp-2wxh>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-6763>
- <https://github.com/jetty/jetty.project/pull/12012>
- <https://github.com/jetty/jetty.project>
- <https://gitlab.eclipse.org/security/cve-assignement/-/issues/25>
- <https://security.netapp.com/advisory/ntap-20250306-0005>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-qh8g-58pp-2wxh>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-qh8g-58pp-2wxh/>. Everything for agents: <https://agentprime.io/llms.txt>.
