# Mattermost allows authenticated users to write files to arbitrary locations in github.com/mattermost/mattermost-server

Advisory record · `GHSA-qh58-9v3j-wcjc`

- **Identifiers:** `GHSA-qh58-9v3j-wcjc` · `CVE-2025-4981` · `GO-2025-3769`
- **State:** Confirmed
- **Severity:** CVSS 9.9 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-427](https://cwe.mitre.org/data/definitions/427.html)
- **Tags:** [CWE-427](https://agentprime.io/advisories/tag/cwe-427.md)
- **Published:** 28 Jul 2025
- **Updated:** 3 Mar 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Jul 2025, 19:57 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.9: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `github.com/mattermost/mattermost-server` (Go): affected `<0.0.0-20250519205859-65aec10162f6 || >=9.11.0+incompatible, <9.11.16+incompatible || >=10.5.0+incompatible, <10.5.6+incompatible || >=10.6.0+incompatible, <10.6.6+incompatible || >=10.7.0+incompatible, <10.7.3+incompatible || >=10.8.0+incompatible, <10.8.1+incompatible`; fixed in `0.0.0-20250519205859-65aec10162f6`, `9.11.16+incompatible`, `10.5.6+incompatible`, `10.6.6+incompatible`, `10.7.3+incompatible`, `10.8.1+incompatible`
- `github.com/mattermost/mattermost-server/v5` (Go): affected `all versions`; no fixed version yet
- `github.com/mattermost/mattermost-server/v6` (Go): affected `all versions`; no fixed version yet
- `github.com/mattermost/mattermost/server/v8` (Go): affected `<8.0.0-20250519205859-65aec10162f6`; fixed in `8.0.0-20250519205859-65aec10162f6`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.9 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`, from CNA (Mattermost)

- **CISA KEV:** Not listed.
- **EPSS:** 0.010, the 63rd percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 28 Jul 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-qh58-9v3j-wcjc](https://github.com/advisories/GHSA-qh58-9v3j-wcjc)
- [OSV: GHSA-qh58-9v3j-wcjc](https://osv.dev/vulnerability/GHSA-qh58-9v3j-wcjc)
- <https://github.com/advisories/GHSA-qh58-9v3j-wcjc>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-4981>
- <https://github.com/mattermost/mattermost/commit/65aec10162f612d98edf91cc66bf7e781868448b>
- <https://mattermost.com/security-updates>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-qh58-9v3j-wcjc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-qh58-9v3j-wcjc/>. Everything for agents: <https://agentprime.io/llms.txt>.
