# Django vulnerable to Denial of Service

Advisory record · `GHSA-qg2p-9jwr-mmqf`

- **Identifiers:** `GHSA-qg2p-9jwr-mmqf` · `BIT-django-2024-38875` · `CVE-2024-38875` · `PYSEC-2024-56`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-130](https://cwe.mitre.org/data/definitions/130.html) · [CWE-770](https://cwe.mitre.org/data/definitions/770.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md) · [CWE-130](https://agentprime.io/advisories/tag/cwe-130.md)
- **Published:** 10 Jul 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 10 Jul 2024, 06:33 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `django` (PyPI): affected `>=4.2, <4.2.14 || >=5.0, <5.0.7`; fixed in `4.2.14`, `5.0.7`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Django versions 4.2 before 4.2.14 and 5.0 before 5.0.7 are vulnerable to denial of service. The urlize and urlizetrunc functions can be slowed severely by specially crafted input containing a very large number of brackets, and the source does not describe any required access or user action. Upgrade to Django 4.2.14, 5.0.7, or later.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.012, the 67th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:35 UTC: First seen by agentprime
- 31 Oct 2026, 14:35 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-qg2p-9jwr-mmqf)

## Sources

- [GitHub Advisory Database: GHSA-qg2p-9jwr-mmqf](https://github.com/advisories/GHSA-qg2p-9jwr-mmqf)
- [OSV: GHSA-qg2p-9jwr-mmqf](https://osv.dev/vulnerability/GHSA-qg2p-9jwr-mmqf)
- <https://nvd.nist.gov/vuln/detail/CVE-2024-38875>
- <https://github.com/django/django/commit/7285644640f085f41d60ab0c8ae4e9153f0485db>
- <https://github.com/django/django/commit/79f368764295df109a37192f6182fb6f361d85b5>
- <https://docs.djangoproject.com/en/dev/releases/security>
- <https://github.com/django/django>
- <https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2024-56.yaml>
- <https://groups.google.com/forum/#%21forum/django-announce>
- <https://security.netapp.com/advisory/ntap-20240808-0005>
- <https://www.djangoproject.com/weblog/2024/jul/09/security-releases>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-qg2p-9jwr-mmqf>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-qg2p-9jwr-mmqf/>. Everything for agents: <https://agentprime.io/llms.txt>.
