# phpseclib — non-constant-time X25519 scalar multiplication permits full private-key recovery

Advisory record · `GHSA-q97c-8qh3-fpc6`

- **Identifiers:** `GHSA-q97c-8qh3-fpc6` · `CVE-2026-84308` · `PKSA-12sz-bcny-pk4m`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-208](https://cwe.mitre.org/data/definitions/208.html) · [CWE-385](https://cwe.mitre.org/data/definitions/385.html)
- **Tags:** [CWE-208](https://agentprime.io/advisories/tag/cwe-208.md) · [CWE-385](https://agentprime.io/advisories/tag/cwe-385.md)
- **Published:** 8 Sept 2026
- **Updated:** 29 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 8 Sept 2026, 21:24 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `phpseclib/phpseclib` (Packagist): affected `<3.0.57 || >=4.0.0, <4.0.1`; fixed in `3.0.57`, `4.0.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> phpseclib before 3.0.57, and 4.0.0 before 4.0.1, uses a non-constant-time pure-PHP X25519 scalar multiplication whose per-step timing depends on the secret scalar. An attacker who can observe per-step timing or GMP library call counts on the same host, and who knows the victim's public key, can recover a reused long-lived X25519 private key; this was shown in an instrumented model and only applies when the pure-PHP path runs. Upgrade to 3.0.57 or 4.0.1.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 3.1: `CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0033, the 25th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:54 UTC: First seen by agentprime
- 31 Oct 2026, 13:54 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-q97c-8qh3-fpc6)

## Sources

- [GitHub Advisory Database: GHSA-q97c-8qh3-fpc6](https://github.com/advisories/GHSA-q97c-8qh3-fpc6)
- [OSV: GHSA-q97c-8qh3-fpc6](https://osv.dev/vulnerability/GHSA-q97c-8qh3-fpc6)
- <https://github.com/phpseclib/phpseclib/security/advisories/GHSA-q97c-8qh3-fpc6>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-84308>
- <https://github.com/phpseclib/phpseclib/commit/fb56bc5bb9009b54a6c26b31aeec8ed944f17373>
- <https://github.com/phpseclib/phpseclib>
- <https://github.com/phpseclib/phpseclib/releases/tag/3.0.57>
- <https://github.com/phpseclib/phpseclib/releases/tag/4.0.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-q97c-8qh3-fpc6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-q97c-8qh3-fpc6/>. Everything for agents: <https://agentprime.io/llms.txt>.
