# Twisted: HTTP Request Smuggling in twisted.web via a Bare CR or LF in a Header Value

Advisory record · `GHSA-q7qq-6mhp-9rc4`

- **Identifiers:** `GHSA-q7qq-6mhp-9rc4` · `CVE-2026-115877`
- **State:** Confirmed
- **Severity:** CVSS 5.4 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md)
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 23 Oct 2026, 20:44 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `twisted` (PyPI): affected `<26.10.0rc1`; fixed in `26.10.0rc1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Twisted versions before 26.10.0rc1 (including 26.4.0 and earlier) let a bare CR or LF inside an HTTP header value pass validation, so the HTTP server's parser can read the request differently from a front-end proxy that treats a bare LF as a line terminator. An attacker who can send requests through such a proxy can smuggle a request the proxy never sees, which may bypass access controls or poison a shared connection or cache. Upgrade to Twisted 26.10.0rc1 or later; the source gives no workaround.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.4 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0026, the 17th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:08 UTC: First seen by agentprime
- 31 Oct 2026, 14:08 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-q7qq-6mhp-9rc4)

## Sources

- [GitHub Advisory Database: GHSA-q7qq-6mhp-9rc4](https://github.com/advisories/GHSA-q7qq-6mhp-9rc4)
- [OSV: GHSA-q7qq-6mhp-9rc4](https://osv.dev/vulnerability/GHSA-q7qq-6mhp-9rc4)
- <https://github.com/twisted/twisted/security/advisories/GHSA-q7qq-6mhp-9rc4>
- <https://github.com/twisted/twisted/pull/12755>
- <https://github.com/twisted/twisted/commit/022b6f7feb5980166c71f54e2c0d8f4f21ff6e1a>
- <https://github.com/twisted/twisted/commit/1616f702d36eda8990a5a5b22ad70fab140a7eb1>
- <https://github.com/twisted/twisted>
- <https://github.com/twisted/twisted/releases/tag/twisted-26.10.0rc1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-q7qq-6mhp-9rc4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-q7qq-6mhp-9rc4/>. Everything for agents: <https://agentprime.io/llms.txt>.
