# Netty: \[codec-haproxy\] Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion

Advisory record · `GHSA-q6cq-mhr2-jmr5`

- **Identifiers:** `GHSA-q6cq-mhr2-jmr5` · `CVE-2026-55851`
- **State:** Confirmed
- **Severity:** CVSS 8.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-400](https://cwe.mitre.org/data/definitions/400.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 22 Jul 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 Jul 2026, 21:23 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `io.netty:netty-codec-haproxy` (Maven): affected `>=4.2.0.Final, <4.2.16.Final || >=4.1.0.Final, <4.1.136.Final`; fixed in `4.2.16.Final`, `4.1.136.Final`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> GHSA-q6cq-mhr2-jmr5 affects the Netty netty-codec-haproxy package, versions from 4.2.0.Final before 4.2.16.Final and from 4.1.0.Final before 4.1.136.Final. A remote attacker who can send crafted bytes to a server using HAProxyMessageDecoder can exhaust the JVM's direct memory, because the decoder keeps buffering inbound data without limit. Upgrade to 4.2.16.Final or 4.1.136.Final, or later.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.7 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0063, the 50th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:16 UTC: First seen by agentprime
- 31 Oct 2026, 14:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-q6cq-mhr2-jmr5)

## Sources

- [GitHub Advisory Database: GHSA-q6cq-mhr2-jmr5](https://github.com/advisories/GHSA-q6cq-mhr2-jmr5)
- [OSV: GHSA-q6cq-mhr2-jmr5](https://osv.dev/vulnerability/GHSA-q6cq-mhr2-jmr5)
- <https://github.com/netty/netty/security/advisories/GHSA-q6cq-mhr2-jmr5>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-55851>
- <https://github.com/netty/netty/commit/5b68c61f37aa4a3045cba624cbea239655c9003b>
- <https://github.com/netty/netty/commit/bb2ff68a1fb71cb4b0eb9a9e17b66c52aff680c6>
- <https://github.com/netty/netty>
- <https://github.com/netty/netty/releases/tag/netty-4.1.136.Final>
- <https://github.com/netty/netty/releases/tag/netty-4.2.16.Final>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-q6cq-mhr2-jmr5>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-q6cq-mhr2-jmr5/>. Everything for agents: <https://agentprime.io/llms.txt>.
