# ONNX: Denial of service via unchecked expansion of packed sub-byte tensors in ONNX Python APIs

Advisory record · `GHSA-q69g-f4f5-v8m7`

- **Identifiers:** `GHSA-q69g-f4f5-v8m7` · `CVE-2026-115922`
- **State:** Confirmed
- **Severity:** CVSS 6.2 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-789](https://cwe.mitre.org/data/definitions/789.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Oct 2026, 21:16 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `onnx` (PyPI): affected `<1.22.0`; fixed in `1.22.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Affected: the PyPI package onnx, versions before 1.22.0, when materializing packed sub-byte tensors (UINT2, INT2, UINT4, INT4, FLOAT4E2M1) via onnx.numpy_helper.to_array() or onnx.reference.ReferenceEvaluator. An attacker who supplies a small model with a large declared dimension can cause a disproportionately large memory allocation when an application processes it, leading to denial of service; the source does not demonstrate memory corruption or code execution. Upgrade to onnx 1.22.0 or later.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.2 Medium, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0013, the 2nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-q69g-f4f5-v8m7)

## Sources

- [GitHub Advisory Database: GHSA-q69g-f4f5-v8m7](https://github.com/advisories/GHSA-q69g-f4f5-v8m7)
- [OSV: GHSA-q69g-f4f5-v8m7](https://osv.dev/vulnerability/GHSA-q69g-f4f5-v8m7)
- <https://github.com/onnx/onnx/security/advisories/GHSA-q69g-f4f5-v8m7>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-115922>
- <https://github.com/onnx/onnx/pull/8033>
- <https://github.com/onnx/onnx/pull/8038>
- <https://github.com/onnx/onnx/pull/8066>
- <https://github.com/onnx/onnx/commit/05c1bc3bceceb8d3cf11e9e7fc7f19f971c44988>
- <https://github.com/onnx/onnx/commit/8de2cf6aa47928e6515ac6d9e1a8b4758886a7df>
- <https://github.com/onnx/onnx/commit/dce5876d6cc6cc30157af7d26a752ef44976da8e>
- <https://github.com/onnx/onnx>
- <https://github.com/onnx/onnx/releases/tag/v1.22.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-q69g-f4f5-v8m7>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-q69g-f4f5-v8m7/>. Everything for agents: <https://agentprime.io/llms.txt>.
