# In RubyGem excon, interrupted Persistent Connections May Leak Response Data

Advisory record · `GHSA-q58g-455p-8vw9`

- **Identifiers:** `GHSA-q58g-455p-8vw9` · `CVE-2019-16779`
- **State:** Confirmed
- **Severity:** CVSS 5.8 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-362](https://cwe.mitre.org/data/definitions/362.html) · [CWE-664](https://cwe.mitre.org/data/definitions/664.html)
- **Tags:** [Race condition](https://agentprime.io/advisories/tag/race-condition.md) · [CWE-664](https://agentprime.io/advisories/tag/cwe-664.md)
- **Published:** 16 Dec 2019
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Dec 2019, 19:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `excon` (RubyGems): affected `<0.71.0`; fixed in `0.71.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.8 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.017, the 76th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-q58g-455p-8vw9)

## Sources

- [GitHub Advisory Database: GHSA-q58g-455p-8vw9](https://github.com/advisories/GHSA-q58g-455p-8vw9)
- [OSV: GHSA-q58g-455p-8vw9](https://osv.dev/vulnerability/GHSA-q58g-455p-8vw9)
- <https://github.com/excon/excon/security/advisories/GHSA-q58g-455p-8vw9>
- <https://nvd.nist.gov/vuln/detail/CVE-2019-16779>
- <https://github.com/excon/excon/commit/ccb57d7a422f020dc74f1de4e8fb505ab46d8a29>
- <https://github.com/excon/excon>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/excon/CVE-2019-16779.yml>
- <https://lists.debian.org/debian-lts-announce/2020/01/msg00015.html>
- <http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00021.html>
- <http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00062.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-q58g-455p-8vw9>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-q58g-455p-8vw9/>. Everything for agents: <https://agentprime.io/llms.txt>.
