# Rack:: Static header_rules bypass via URL-encoded paths

Advisory record · `GHSA-q4qf-9j86-f5mh`

- **Identifiers:** `GHSA-q4qf-9j86-f5mh` · `CVE-2026-34786`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-180](https://cwe.mitre.org/data/definitions/180.html)
- **Tags:** [CWE-180](https://agentprime.io/advisories/tag/cwe-180.md)
- **Published:** 2 Apr 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 2 Apr 2026, 18:44 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `rack` (RubyGems): affected `<2.2.23 || >=3.0.0.beta1, <3.1.21 || >=3.2.0, <3.2.6`; fixed in `2.2.23`, `3.1.21`, `3.2.6`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0020, the 10th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-q4qf-9j86-f5mh)

## Sources

- [GitHub Advisory Database: GHSA-q4qf-9j86-f5mh](https://github.com/advisories/GHSA-q4qf-9j86-f5mh)
- [OSV: GHSA-q4qf-9j86-f5mh](https://osv.dev/vulnerability/GHSA-q4qf-9j86-f5mh)
- <https://github.com/rack/rack/security/advisories/GHSA-q4qf-9j86-f5mh>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-34786>
- <https://github.com/rack/rack>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2026-34786.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-q4qf-9j86-f5mh>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-q4qf-9j86-f5mh/>. Everything for agents: <https://agentprime.io/llms.txt>.
