# Publify Improper Input Validation vulnerability

Advisory record · `GHSA-q3rm-f527-ghxj`

- **Identifiers:** `GHSA-q3rm-f527-ghxj` · `BIT-publify-2023-0299` · `CVE-2023-0299`
- **State:** Confirmed
- **Severity:** CVSS 8.4 High
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html)
- **Tags:** [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md)
- **Published:** 14 Jan 2023
- **Updated:** 6 Dec 2023
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 Jan 2023, 15:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `publify_core` (RubyGems): affected `<9.2.10`; fixed in `9.2.10`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.4 High, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H`, from CNA (@huntrdev)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0094, the 61st percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 14 Jan 2023. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-q3rm-f527-ghxj](https://github.com/advisories/GHSA-q3rm-f527-ghxj)
- [OSV: GHSA-q3rm-f527-ghxj](https://osv.dev/vulnerability/GHSA-q3rm-f527-ghxj)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-0299>
- <https://github.com/publify/publify/commit/ca46da283572b4f8c0b5aa245008756c8a5fd1b1>
- <https://github.com/publify/publify_core/commit/34f6e9c98e0e3b3f9896f9676b3d6442220e2b4e>
- <https://github.com/publify/publify>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/publify_core/CVE-2023-0299.yml>
- <https://huntr.dev/bounties/0049774b-1857-46dc-a834-f1fb15138c53>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-q3rm-f527-ghxj>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-q3rm-f527-ghxj/>. Everything for agents: <https://agentprime.io/llms.txt>.
