# follow-redirects array-form headers bypass cross-origin credential stripping

Advisory record · `GHSA-q3jh-wrc6-jgq8`

- **Identifiers:** `GHSA-q3jh-wrc6-jgq8` · `CVE-2026-111756`
- **State:** Confirmed
- **Severity:** CVSS 8.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-200](https://cwe.mitre.org/data/definitions/200.html) · [CWE-212](https://cwe.mitre.org/data/definitions/212.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-212](https://agentprime.io/advisories/tag/cwe-212.md)
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Oct 2026, 17:58 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `follow-redirects` (npm): affected `>=1.16.0, <1.16.1`; fixed in `1.16.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> follow-redirects versions from 1.16.0 before 1.16.1 fail to strip credential headers, such as Authorization, Cookie and Proxy-Authorization, when the caller supplies headers as an array, a form Node's http.request accepts. An attacker who controls a redirect target that the application contacts can receive those headers after a cross-origin redirect, and in cleartext on a protocol downgrade. Upgrade to follow-redirects 1.16.1.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.2 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0047, the 40th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-q3jh-wrc6-jgq8)

## Sources

- [GitHub Advisory Database: GHSA-q3jh-wrc6-jgq8](https://github.com/advisories/GHSA-q3jh-wrc6-jgq8)
- [OSV: GHSA-q3jh-wrc6-jgq8](https://osv.dev/vulnerability/GHSA-q3jh-wrc6-jgq8)
- <https://github.com/follow-redirects/follow-redirects/security/advisories/GHSA-q3jh-wrc6-jgq8>
- <https://github.com/follow-redirects/follow-redirects/commit/9865ca45490e4d0f7b6944870318408344570aff>
- <https://github.com/follow-redirects/follow-redirects>
- <https://github.com/follow-redirects/follow-redirects/releases/tag/v1.16.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-q3jh-wrc6-jgq8>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-q3jh-wrc6-jgq8/>. Everything for agents: <https://agentprime.io/llms.txt>.
