# net-imap has quadratic complexity when reading response literals

Advisory record · `GHSA-q2mw-fvj9-vvcw`

- **Identifiers:** `GHSA-q2mw-fvj9-vvcw` · `CVE-2026-42245`
- **State:** Confirmed
- **Severity:** CVSS 2.3 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-407](https://cwe.mitre.org/data/definitions/407.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 4 May 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 4 May 2026, 22:02 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `net-imap` (RubyGems): affected `>=0.6.0, <0.6.4 || >=0.5.0, <0.5.14 || <0.4.24`; fixed in `0.6.4`, `0.5.14`, `0.4.24`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.3 Low, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0041, the 35th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-q2mw-fvj9-vvcw)

## Sources

- [GitHub Advisory Database: GHSA-q2mw-fvj9-vvcw](https://github.com/advisories/GHSA-q2mw-fvj9-vvcw)
- [OSV: GHSA-q2mw-fvj9-vvcw](https://osv.dev/vulnerability/GHSA-q2mw-fvj9-vvcw)
- <https://github.com/ruby/net-imap/security/advisories/GHSA-q2mw-fvj9-vvcw>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-42245>
- <https://github.com/ruby/net-imap/commit/6091f7d6b1f3514cafbfe39c76f2b5d73de3ca96>
- <https://github.com/ruby/net-imap/commit/88d95231fc8afef11c1f074453f7d75b68c9dfda>
- <https://github.com/ruby/net-imap/commit/de685f91a4a4cc75eb80da898c2bf8af08d34819>
- <https://github.com/ruby/net-imap>
- <https://github.com/ruby/net-imap/releases/tag/v0.4.24>
- <https://github.com/ruby/net-imap/releases/tag/v0.5.14>
- <https://github.com/ruby/net-imap/releases/tag/v0.6.4>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/net-imap/CVE-2026-42245.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-q2mw-fvj9-vvcw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-q2mw-fvj9-vvcw/>. Everything for agents: <https://agentprime.io/llms.txt>.
