# Moby has an Off-by-one error in its plugin privilege validation

Advisory record · `GHSA-pxq6-2prw-chj9`

- **Identifiers:** `GHSA-pxq6-2prw-chj9` · `CVE-2026-33997` · `GO-2026-4883`
- **State:** Confirmed
- **Severity:** CVSS 6.8 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-193](https://cwe.mitre.org/data/definitions/193.html) · [CWE-266](https://cwe.mitre.org/data/definitions/266.html)
- **Tags:** [Privilege escalation](https://agentprime.io/advisories/tag/privilege-escalation.md) · [CWE-193](https://agentprime.io/advisories/tag/cwe-193.md)
- **Published:** 27 Mar 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 Mar 2026, 17:38 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/docker/docker` (Go): affected `all versions`; no fixed version yet
- `github.com/moby/moby/v2` (Go): affected `<2.0.0-beta.8`; fixed in `2.0.0-beta.8`
- `github.com/moby/moby` (Go): affected `all versions`; no fixed version yet

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Moby (github.com/docker/docker and github.com/moby/moby, with no fixed version listed) contains an off-by-one error in plugin privilege validation during plugin installation, so the daemon may accept a privilege set that differs from the one the user approved. An attacker would need to get a malicious plugin installed, and the source states that Docker Desktop does not support plugins. Upgrade github.com/moby/moby/v2 to 2.0.0-beta.8 or later; no fixed version is listed for the other two packages.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.8 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0040, the 34th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:14 UTC: First seen by agentprime
- 31 Oct 2026, 14:14 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-pxq6-2prw-chj9)

## Sources

- [GitHub Advisory Database: GHSA-pxq6-2prw-chj9](https://github.com/advisories/GHSA-pxq6-2prw-chj9)
- [OSV: GHSA-pxq6-2prw-chj9](https://osv.dev/vulnerability/GHSA-pxq6-2prw-chj9)
- <https://github.com/moby/moby/security/advisories/GHSA-pxq6-2prw-chj9>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-33997>
- <https://github.com/moby/moby/commit/f4d6f25bf0c3fa12d4968320a45685947756a22a>
- <https://docs.docker.com/engine/extend/legacy_plugins>
- <https://github.com/moby/moby>
- <https://github.com/moby/moby/releases/tag/docker-v29.3.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-pxq6-2prw-chj9>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-pxq6-2prw-chj9/>. Everything for agents: <https://agentprime.io/llms.txt>.
