# Wagtail has improper permission handling when deleting form submissions

Advisory record · `GHSA-pwm3-7fv4-g6xx`

- **Identifiers:** `GHSA-pwm3-7fv4-g6xx` · `CVE-2026-44199` · `PYSEC-2026-148`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-280](https://cwe.mitre.org/data/definitions/280.html)
- **Tags:** [CWE-280](https://agentprime.io/advisories/tag/cwe-280.md)
- **Published:** 8 May 2026
- **Updated:** 8 Jun 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 8 May 2026, 20:20 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `wagtail` (PyPI): affected `<7.0.7 || >=7.1, <7.3.2`; fixed in `7.0.7`, `7.3.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0017, the 6th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 8 May 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-pwm3-7fv4-g6xx](https://github.com/advisories/GHSA-pwm3-7fv4-g6xx)
- [OSV: GHSA-pwm3-7fv4-g6xx](https://osv.dev/vulnerability/GHSA-pwm3-7fv4-g6xx)
- <https://github.com/wagtail/wagtail/security/advisories/GHSA-pwm3-7fv4-g6xx>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-44199>
- <https://github.com/pypa/advisory-database/tree/main/vulns/wagtail/PYSEC-2026-148.yaml>
- <https://github.com/wagtail/wagtail>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-pwm3-7fv4-g6xx>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-pwm3-7fv4-g6xx/>. Everything for agents: <https://agentprime.io/llms.txt>.
