# Supply chain compromise via malicious package versions (@cap-js/sqlite, @cap-js/postgres, @cap-js/db-service)

Advisory record · `GHSA-pvw4-cvr4-97p8`

- **Identifiers:** `GHSA-pvw4-cvr4-97p8` · `CVE-2026-46421`
- **State:** Confirmed
- **Severity:** CVSS 9.3 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-506](https://cwe.mitre.org/data/definitions/506.html)
- **Tags:** [CWE-506](https://agentprime.io/advisories/tag/cwe-506.md)
- **Published:** 20 May 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 May 2026, 15:33 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.3: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `@cap-js/sqlite` (npm): affected `>=2.2.2, <2.3.0`; fixed in `2.3.0`
- `@cap-js/postgres` (npm): affected `>=2.2.2, <2.3.0`; fixed in `2.3.0`
- `@cap-js/db-service` (npm): affected `>=2.10.1, <2.11.0`; fixed in `2.11.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.3 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0052, the 44th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 20 May 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-pvw4-cvr4-97p8](https://github.com/advisories/GHSA-pvw4-cvr4-97p8)
- [OSV: GHSA-pvw4-cvr4-97p8](https://osv.dev/vulnerability/GHSA-pvw4-cvr4-97p8)
- <https://github.com/cap-js/cds-dbs/security/advisories/GHSA-pvw4-cvr4-97p8>
- <https://github.com/cap-js/cds-dbs>
- <https://me.sap.com/notes/3747787>
- <https://www.sap.com/documents/2026/05/8203a8b9-4d7f-0010-bca6-c68f7e60039b.html>
- <https://www.stepsecurity.io/blog/a-mini-shai-hulud-has-appeared>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-pvw4-cvr4-97p8>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-pvw4-cvr4-97p8/>. Everything for agents: <https://agentprime.io/llms.txt>.
