# Incorrect control flow in Jenkins Gradle Plugin breaks credentials masking in the build log

Advisory record · `GHSA-pvjf-4hfg-wr84`

- **Identifiers:** `GHSA-pvjf-4hfg-wr84` · `CVE-2023-39152`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-670](https://cwe.mitre.org/data/definitions/670.html)
- **Tags:** [CWE-670](https://agentprime.io/advisories/tag/cwe-670.md)
- **Published:** 26 Jul 2023
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 26 Jul 2023, 15:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.jenkins-ci.plugins:gradle` (Maven): affected `<2.8.1`; fixed in `2.8.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The Jenkins Gradle Plugin (org.jenkins-ci.plugins:gradle) versions before 2.8.1 are affected. In some circumstances, credentials are not masked with asterisks in the build log, so they can appear in plain text there. An attacker would need to be able to read the build log, and the source gives few details on the exact conditions. Upgrade to version 2.8.1, which fixes the issue.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0077, the 55th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:18 UTC: First seen by agentprime
- 31 Oct 2026, 14:18 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-pvjf-4hfg-wr84)

## Sources

- [GitHub Advisory Database: GHSA-pvjf-4hfg-wr84](https://github.com/advisories/GHSA-pvjf-4hfg-wr84)
- [OSV: GHSA-pvjf-4hfg-wr84](https://osv.dev/vulnerability/GHSA-pvjf-4hfg-wr84)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-39152>
- <https://www.jenkins.io/security/advisory/2023-07-26/#SECURITY-3208>
- <http://www.openwall.com/lists/oss-security/2023/07/26/2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-pvjf-4hfg-wr84>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-pvjf-4hfg-wr84/>. Everything for agents: <https://agentprime.io/llms.txt>.
