# resdata has Classic Buffer Overflow, Improper Validation of Array Index, NULL Pointer Dereference and Out-of-bounds Read

Advisory record · `GHSA-pr85-w493-9w3x`

- **Identifiers:** `GHSA-pr85-w493-9w3x` · `CVE-2026-55209` · `PYSEC-2026-3694`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-120](https://cwe.mitre.org/data/definitions/120.html) · [CWE-125](https://cwe.mitre.org/data/definitions/125.html) · [CWE-129](https://cwe.mitre.org/data/definitions/129.html) · [CWE-476](https://cwe.mitre.org/data/definitions/476.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md) · [CWE-129](https://agentprime.io/advisories/tag/cwe-129.md)
- **Published:** 18 Aug 2026
- **Updated:** 19 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 18 Aug 2026, 20:11 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `resdata` (PyPI): affected `<6.2.9`; fixed in `6.2.9`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> resdata versions before 6.2.9 do not correctly validate input in GRDECL files, which can lead to buffer overflow, array index, NULL pointer and out-of-bounds read problems. An attacker who can supply a crafted GRDECL file to resdata, for example through a web service that parses untrusted files, may be able to affect the program. Upgrade resdata to version 6.2.9 or later.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0078, the 56th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:39 UTC: First seen by agentprime
- 31 Oct 2026, 14:39 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-pr85-w493-9w3x)

## Sources

- [GitHub Advisory Database: GHSA-pr85-w493-9w3x](https://github.com/advisories/GHSA-pr85-w493-9w3x)
- [OSV: GHSA-pr85-w493-9w3x](https://osv.dev/vulnerability/GHSA-pr85-w493-9w3x)
- <https://github.com/equinor/resdata/security/advisories/GHSA-pr85-w493-9w3x>
- <https://github.com/equinor/resdata>
- <https://github.com/equinor/resdata/releases/tag/6.2.9>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-pr85-w493-9w3x>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-pr85-w493-9w3x/>. Everything for agents: <https://agentprime.io/llms.txt>.
