# python-sql SQL injection vulnerability

Advisory record · `GHSA-pq9p-pc3p-9hm4`

- **Identifiers:** `GHSA-pq9p-pc3p-9hm4` · `CVE-2024-9774` · `PYSEC-2026-1855`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-150](https://cwe.mitre.org/data/definitions/150.html)
- **Tags:** [CWE-150](https://agentprime.io/advisories/tag/cwe-150.md)
- **Published:** 27 Dec 2024
- **Updated:** 7 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 Dec 2024, 03:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `python-sql` (PyPI): affected `<1.5.2`; fixed in `1.5.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N`, from CNA (redhat)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0068, the 52nd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 27 Dec 2024. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-pq9p-pc3p-9hm4](https://github.com/advisories/GHSA-pq9p-pc3p-9hm4)
- [OSV: GHSA-pq9p-pc3p-9hm4](https://osv.dev/vulnerability/GHSA-pq9p-pc3p-9hm4)
- <https://nvd.nist.gov/vuln/detail/CVE-2024-9774>
- <https://access.redhat.com/security/cve/CVE-2024-9774>
- <https://bugs.tryton.org/python-sql/93>
- <https://bugzilla.redhat.com/show_bug.cgi?id=2332734>
- <https://discuss.tryton.org/t/security-release-for-issue-93/7889>
- <https://discuss.tryton.org/t/security-release-for-issue-93/7889/3>
- <https://foss.heptapod.net/tryton/python-sql/-/commit/f20551bbb8b3b4c4dd0a2c3d36f377bff6f2f349>
- <https://github.com/tryton/python-sql>
- <https://lists.debian.org/debian-lts-announce/2024/10/msg00023.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-pq9p-pc3p-9hm4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-pq9p-pc3p-9hm4/>. Everything for agents: <https://agentprime.io/llms.txt>.
