# Quasar Framework: Stored/Reflected XSS via unescaped SSR meta tag rendering in getHead()

Advisory record · `GHSA-pq96-jpmf-w254`

- **Identifiers:** `GHSA-pq96-jpmf-w254` · `CVE-2026-106102`
- **State:** Confirmed
- **Severity:** CVSS 10.0 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html) · [CWE-116](https://cwe.mitre.org/data/definitions/116.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md) · [CWE-116](https://agentprime.io/advisories/tag/cwe-116.md)
- **Published:** 7 Oct 2026
- **Updated:** 7 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 7 Oct 2026, 16:14 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 10.0: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `quasar` (npm): affected `<2.22.0`; fixed in `2.22.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Quasar framework versions before 2.22.0 render page title and meta/link/script tag values into server-side HTML without escaping, so text passed to useMeta() can break out of its tag and inject markup, including scripts. An attacker who can influence that text, such as a blog title or a user display name, can get script to run in the origin of every visitor to the affected page, with no authentication required. Upgrade the quasar package to version 2.22.0 or later.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 10.0 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0030, the 22nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-pq96-jpmf-w254)

## Sources

- [GitHub Advisory Database: GHSA-pq96-jpmf-w254](https://github.com/advisories/GHSA-pq96-jpmf-w254)
- [OSV: GHSA-pq96-jpmf-w254](https://osv.dev/vulnerability/GHSA-pq96-jpmf-w254)
- <https://github.com/quasarframework/quasar/security/advisories/GHSA-pq96-jpmf-w254>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-106102>
- <https://github.com/quasarframework/quasar/commit/11505afe5b5218f2c468f130181815b898fd1e40>
- <https://github.com/quasarframework/quasar>
- <https://github.com/quasarframework/quasar/releases/tag/quasar-v2.22.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-pq96-jpmf-w254>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-pq96-jpmf-w254/>. Everything for agents: <https://agentprime.io/llms.txt>.
